403 error causing registration problem

Forum Forums ZM AJAX Login & Register 403 error causing registration problem

This topic contains 7 replies, has 2 voices, and was last updated by  Zane M. Kolnik 5 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #246 Reply

    Charly Anderson
    Participant

    Good afternoon,

    I was using the free version of your plugin but the registration function was not working – the button was not clickable and nothing happened.

    I paid for someone to look at my site and see what the problem is. It turned out that the register.css and register.js were being blocked and sending back 403 errors.

    The person helping me, renamed these files both to creg and updated the main plugin.php file with the change of filename – it worked!!

    Problem is, I have just purchased the pro version of your plugin… same problem, registration is not working.

    I looked into the theme file to implement the changes as before however… the file structure is completely different.

    Please can you help me resolve this – my site is due to launch so it is really urgent 🙁

    #247 Reply

    Zane M. Kolnik
    Keymaster

    Hi Charly,

    The issue your having, 403, is file permission issue where the file is restricted, which it shouldn’t be.

    To fix this set the permissions to be readable for the files causing the 403 error.

    The register file can be found at: zm-ajax-login-register-pro/assets/stylesheets/register.css and zm-ajax-login-register-pro/assets/javascripts/register.js

    #251 Reply

    Charly Anderson
    Participant

    Thanks for your reply – I changed the permissions and this worked – thank you so much.

    I have one other problem which I hope you might also be able to help me with (sorry!).

    I have activated the “approve all registrations”, it allows people to register no probs. However, even though I approve them, nothing happens. When you try to log in and click the submit button, there’s nothing.

    However, if you enter login details of an account created via the dashboard, you log in fine as normal.

    Any ideas? The website address is here.

    Thanks in advance 🙂

    #253 Reply

    Zane M. Kolnik
    Keymaster

    Hi Charly,

    From what I gather your using “manual approval” and approving members, yet they are not able to login? If so can you confirm they are receiving a confirmation email? If not, which admin page are you using for the option “approve all registrations”?

    P.S., I moved this into the Pro forum for paid members.

    #259 Reply

    Charly Anderson
    Participant

    Hello I can see this now (although apparently my pro access has expired).

    I am receiving a confirmation email saying that the account has been approved.

    I am using the settings within the plugin, not the main wordpress settings.

    #260 Reply

    Charly Anderson
    Participant

    Ok… I think I might have found the problem… watch this space…

    #261 Reply

    Charly Anderson
    Participant

    Apologies… it was completely MY fault!

    I didn’t realise “approve registrations” was also ticked under my security plugin settings – didn’t click until you asked me.

    Thanks so much for your help and patience… apologies again

    #262 Reply

    Zane M. Kolnik
    Keymaster

    No problem 🙂 thats what we’re here for.

Viewing 8 posts - 1 through 8 (of 8 total)
Reply To: 403 error causing registration problem

This topic is marked as closed to new replies, however your posting capabilities still allow you to do so.